ZOLL Billing - Customers experiencing latency and system errors

Incident Report for ZOLLOnline

Resolved

SERVICE RESTORED: ZOLL Billing fully operational. We apologize for any inconvenience. Review underway to prevent recurrence.
Posted Jun 23, 2025 - 14:06 MDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 23, 2025 - 13:19 MDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 23, 2025 - 12:34 MDT

Identified

ISSUE UPDATE: Cause identified for ZOLL Billing, fix in progress. Next update in 30 minutes. Thank you for your patience.
Posted Jun 23, 2025 - 11:59 MDT

Update

We are continuing to investigate this issue.
Posted Jun 23, 2025 - 11:29 MDT

Investigating

ISSUE ALERT: ZOLL Billing under investigation. Expect an update within 30 minutes. We value your understanding.
Posted Jun 23, 2025 - 10:57 MDT
This incident affected: ZOLL Billing (All Services - ZOLL Billing).