ZOLL Dispatch - Service Disruption - intermittent connectivity or performance issues

Incident Report for ZOLLOnline

Resolved

SERVICE RESTORED: ZOLL Dispatch - Service Disruption fully operational. We apologize for any inconvenience. Review underway to prevent recurrence.
Posted May 10, 2026 - 07:27 MDT

Update

MONITORING: ZOLL Dispatch - Service Disruption fix applied, confirming stability. Final update in 30 minutes. Thanks for standing by.
Posted May 10, 2026 - 07:14 MDT

Monitoring

MONITORING: ZOLL Dispatch - Service Disruption fix applied, confirming stability. Final update in 30 minutes. Thanks for standing by.
Posted May 10, 2026 - 06:42 MDT

Update

ISSUE ALERT: ZOLL Dispatch - Service Disruption under investigation. Expect an update within 30 minutes. We value your understanding.
Posted May 10, 2026 - 06:20 MDT

Investigating

ISSUE ALERT: ZOLL Dispatch - Service Disruption under investigation. Expect an update within 30 minutes. We value your understanding.
Posted May 10, 2026 - 05:54 MDT
This incident affected: ZOLL Dispatch (All Services - ZOLL Dispatch).