AR Boost - not returning CMS Results

Incident Report for ZOLLOnline

Resolved

RESOLVED: ZOLL AR Boost CMS Results are fully operational. A detailed update has been shared with customers. We apologize for any inconvenience and are reviewing the incident internally.
Posted May 20, 2026 - 15:19 MDT

Investigating

We are currently experiencing an issue impacting MBI Discovery. Our team is actively investigating and working to restore service as quickly as possible.
Posted May 15, 2026 - 08:11 MDT
This incident affected: ZOLL AR Boost (Insurance Verifier/Insurance Discovery).