SERVICE RESTORED: ZOLL ISSUE UPDATE: ZOLL MCC & @Work inability to schedule trips is fully operational. We apologize for any inconvenience. Review underway to prevent recurrence.
Posted May 05, 2026 - 11:57 MDT
Update
ISSUE UPDATE: Cause identified for ZOLL ISSUE UPDATE: ZOLL MCC & @Work inability to schedule trips is under investigation. Next update in 30 minutes. Thank you for your patience.
Posted May 05, 2026 - 11:42 MDT
Update
ISSUE UPDATE: Cause identified for ZOLL ISSUE UPDATE: ZOLL MCC & @Work inability to schedule trips is under investigation. Next update in 30 minutes. Thank you for your patience.
Posted May 05, 2026 - 10:56 MDT
Identified
ISSUE UPDATE: Cause identified for ZOLL MCC & @Work inability to schedule trips is under investigation. Next update in 30 minutes. Thank you for your patience.
Posted May 05, 2026 - 10:23 MDT
Investigating
ISSUE ALERT: ZOLL MCC & @Work/inability to schedule MCC trips is under investigation. Expect an update within 30 minutes. We value your understanding.
Posted May 05, 2026 - 09:52 MDT
This incident affected: www.zollonline.com (Application - @Work, Application - Mobile Care Connect).