ZOLL Online Billing - Imports impacted

Incident Report for ZOLLOnline

Resolved

SERVICE RESTORED: ZOLL Billing imports fully operational. We apologize for any inconvenience. Review underway to prevent recurrence.
Posted Nov 05, 2025 - 12:37 MST

Update

We are continuing to investigate this issue.
Posted Nov 05, 2025 - 12:00 MST

Update

We are continuing to investigate this issue.
Posted Nov 05, 2025 - 11:25 MST

Update

We are continuing to investigate this issue.
Posted Nov 05, 2025 - 10:54 MST

Investigating

ISSUE ALERT: ZOLL Billing under investigation. Expect an update within 30 minutes. We value your understanding.
Posted Nov 05, 2025 - 10:24 MST
This incident affected: ZOLL Billing (NEMSIS Import, RescueNet Dispatch Integration).