SERVICE RESTORED: ZOLL emsCharts - The incident affecting ZOLL emsCharts EKG vital signs imports has been resolved. Service has been restored and new imports are processing normally. We are currently processing a backlog of data from the impact period, which may cause a slight delay in those records appearing. Thank you for your patience.
Posted May 12, 2026 - 18:21 MDT
Monitoring
MONITORING: ZOLL emsCharts fix has been applied and we are currently monitoring system performance as the backlog of vital signs imports processes. Customers should see service returning to normal. If you continue to experience issues, please contact Support. Next update by 17:30 MST or sooner upon change.
Posted May 12, 2026 - 17:33 MDT
Identified
ISSUE UPDATE: Cause identified for ZOLL emsCharts, The cause of the issue impacting ZOLL emsCharts vital signs imports has been identified. We are currently working on a fix to restore service. We will provide our next update by 17:00 MST.
Posted May 12, 2026 - 17:13 MDT
Update
ISSUE ALERT: ZOLL emsCharts under investigation. We are continuing to investigate the issue impacting ZOLL emsCharts vital signs imports. Engineering is actively working to identify the cause and restore service. Our next update will be provided by 16:30 MST.
Posted May 12, 2026 - 16:56 MDT
Update
ISSUE ALERT: ZOLL emsCharts under investigation. We are continuing to investigate the issue impacting ZOLL emsCharts vital signs imports. Engineering is evaluating restoration paths to resume normal service. Our next update will be provided by 16:00 MST.
Posted May 12, 2026 - 16:26 MDT
Update
ISSUE ALERT: ZOLL emsCharts under investigation. We are investigating an issue with ZOLL emsCharts where vital signs from Zenix or X-Series monitors are not importing as expected. Our engineering team is currently working to identify the cause and restore full functionality. We will provide our next update by 15:30
Posted May 12, 2026 - 16:00 MDT
Investigating
ZOLL EKG's are lacking the vital signs when importing into emsCharts
We have detected an incident related to our SaaS Online product suite. Our support team is investigating the issue and will provide an initial update within the next 30 minutes.
Posted May 12, 2026 - 15:25 MDT
This incident affected: ZOLL emsCharts (ZOLL EKG).