ZOLL Billing - Severe Latency for MCM

Incident Report for ZOLLOnline

Resolved

SERVICE RESTORED: ZOLL Billing fully operational. We apologize for any inconvenience. Review underway to prevent recurrence.
Posted Dec 11, 2025 - 08:27 MST

Monitoring

MONITORING: ZOLL Billing fix applied, confirming stability. Final update in 30 minutes. Thanks for standing by.
Posted Dec 11, 2025 - 07:50 MST

Identified

ISSUE UPDATE: Cause identified for ZOLL billing fix in progress. Next update in 30 minutes. Thank you for your patience.
Posted Dec 11, 2025 - 07:12 MST

Investigating

ISSUE ALERT: ZOLL [ZOLL Billing] under investigation. Expect an update within 30 minutes. We value your understanding.
Posted Dec 11, 2025 - 06:28 MST
This incident affected: ZOLL Billing (All Services - ZOLL Billing).