ZOLL Billing - Claim Submissions

Incident Report for ZOLLOnline

Resolved

The incident has been resolved, and our system is now fully operational. We apologize for any inconvenience this may have caused and appreciate your patience and understanding during this time. We will continue to monitor the system to ensure that normal operations are maintained.
Posted Dec 05, 2025 - 06:30 MST

Monitoring

We’ve identified the issue and are actively working toward a solution
Posted Dec 04, 2025 - 11:00 MST
This incident affected: ZOLL Billing (Claim Submissions).