SERVICE RESTORED: ZOLL Billing/AR Boost fully operational. Microsoft 365 & Amazon Web Services (AWS) network issues appear to be resolved. AR Boost connection to impacted payors is now restored. We will continue to monitor and send additional notifications if new issues arise.
We apologize for any inconvenience.
Posted Oct 29, 2025 - 15:10 MDT
Update
ISSUE UPDATE: Cause identified for ZOLL Billing/AR Boost / Insurance Discovery and Verifier not working in system.
Microsoft 365 & Amazon Web Services (AWS) are currently experiencing network issues that may cause slow or limited access to Microsoft 365 applications and related services. These issues are causing system slowness due to a lag in transaction times with payers and clearinghouses. AR Boost transactions may be timing out as a result of these network issues with our downstream vendors
We are continuing to work on a fix for this issue .
Next update in 2 hours unless we get news sooner.
Posted Oct 29, 2025 - 13:04 MDT
Update
ISSUE UPDATE: Cause identified for ZOLL Billing/AR Boost / Insurance Discovery and Verifier not working in system.
Microsoft 365 & Amazon Web Services (AWS) are currently experiencing network issues that may cause slow or limited access to Microsoft 365 applications and related services. These issues are causing system slowness due to a lag in transaction times with payers and clearinghouses. AR Boost transactions may be timing out as a result of these network issues with our downstream vendors.
We are continuing to work on a fix for this issue .
Next update in 60 minutes unless we get news sooner.
Posted Oct 29, 2025 - 12:03 MDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 29, 2025 - 11:54 MDT
Update
ISSUE UPDATE: Cause identified for ZOLL Billing/AR Boost / Insurance Discovery and Verifier not working in system.
Microsoft 365 & Amazon Web Services (AWS) are currently experiencing network issues that may cause slow or limited access to Microsoft 365 applications and related services. These issues are causing system slowness due to a lag in transaction times with payers and clearinghouses. AR Boost transactions may be timing out as a result of these network issues with our downstream vendors.
Next update in 30 minutes.
Thank you for your patience.
Posted Oct 29, 2025 - 11:33 MDT
Identified
ISSUE UPDATE: Cause identified for ZOLL Billing/AR Boost / Insurance Discovery and Verifier not working in system, some payors are experiencing timeouts due to an outage with multiple vendors. We are working to get this resolved with them as soon as possible.. Next update in 30 minutes. Thank you for your patience.
Posted Oct 29, 2025 - 11:03 MDT
This incident affected: ZOLL AR Boost (Insurance Verifier/Insurance Discovery) and ZOLL Billing (Insurance and Demographic Services).