ZOLL Billing - Imports not processing

Incident Report for ZOLLOnline

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 12:37 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 03, 2025 - 09:53 MST

Investigating

We have detected an incident related to our SaaS Online product suite. Our support team is investigating the issue and will provide an initial update within the next 30 minutes.
Posted Dec 03, 2025 - 05:53 MST
This incident affected: ZOLL Billing (NEMSIS Import).