ZOLL Billing Pro Portal Interruption

Incident Report for ZOLLOnline

Resolved

SERVICE RESTORED: ZOLL Billing Pro fully operational. We apologize for any inconvenience. Review underway to prevent recurrence.
Posted Oct 24, 2025 - 07:32 MDT

Monitoring

ZOLL - Billing Pro - The BillingPro portal experienced an interruption this morning, the service has been restored and is now operating normally. We are continuing to monitor to ensure stability.
Thank you for your patience. Thanks for standing by.
Posted Oct 24, 2025 - 07:16 MDT
This incident affected: ZOLL AR Boost (RescueNet Billing Pro).