ZOLL Billing -Outage
Incident Report for ZOLLOnline
Resolved
This incident has been resolved.
Posted Sep 19, 2023 - 07:37 MDT
Update
We are continuing to investigate this issue.
Posted Sep 19, 2023 - 07:36 MDT
Update
We are continuing to investigate this issue.
Posted Sep 19, 2023 - 07:35 MDT
Update
We are continuing to investigate this issue.
Posted Sep 19, 2023 - 04:21 MDT
Update
We have detected an incident related to our SaaS Online product suite. Our support team is investigating the issue and will provide an initial update within the next 30 minutes.
Posted Sep 19, 2023 - 04:09 MDT
Investigating
We are currently investigating this issue.
Posted Sep 19, 2023 - 03:47 MDT
This incident affected: www.zollonline.com (Application - Insights, Application - Mobile Care Connect, Application - ZOLL Billing).